読者です 読者をやめる 読者になる 読者になる

牌語備忘録 -pygo

あくまでもメモです。なるべくオフィシャルの情報を参照してください。

牌語備忘録 -pygo

"npm install -g spine.app hem" とかすると "Segmentation fault: 11" となってインストールできない件。

Javascript

(MacOSX10.7, node0.8.9, npm1.1.61)

問題

MacPorts で node0.8.9, npm1.1.61をインストールした環境で npm install すると入らない

$ npm install -g spine.app hem
Segmentation fault: 11

解決策?

pkg でインストール

MacPortsインスコした nodejs、npm をアンインストールして
NPM公式サイトから node-v0.8.9.pkg をダウンロドしてインスコ。(node, npm 入る)
で Segmentation fault: がでなくなり、インストールできるようになった。
とりあえず。
なんでこうなるのか? MacPorts側のパッケージのbug?