読者です 読者をやめる 読者になる 読者になる

牌語備忘録 -pygo

あくまでもメモです。なるべくオフィシャルの情報を参照してください。

牌語備忘録 -pygo

Emacs 24.3 と 24.4 以降で設定を分岐させたいメモ

Emacs

24.4 にアプデしたら package-desc-vers でエラーになるから対処。

でも同じ init.el を 24.3 で使い回すこともあるのでこんな感じにしてみた。

(defvar is-24-4-later (and (<= 24 emacs-major-version) (<= 4 emacs-minor-version)))

(when is-24-4-later
    (fset 'package-desc-vers 'package--ac-desc-version)
    )

もっとスマートな書き方ないかと思ったけど取りあえず動くからまあいいか