読者です 読者をやめる 読者になる 読者になる

牌語備忘録 -pygo

あくまでもメモです。なるべくオフィシャルの情報を参照してください。

牌語備忘録 -pygo

Python の pandas で openpyxl のエラーが出る件のメモ

Python

(python2.7.7)

pandas 使うとエラー出ちゃう

$ pip install pandas
$ ipython

In [1]: import pandas
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pandas/io/excel.py:626: UserWarning: Installed openpyxl is not supported at this time. Use >=1.6.1 and <2.0.0.

In [2]: pandas.__version__
Out[2]: '0.14.0'

In [3]: import openpyxl

In [4]: openpyxl.__version__
Out[4]: '2.0.3'

1.6.1 ~ 2.0.0 の openpyxl を使えと?

アンインストールしてダウングレードする

$ pip uninstall openpyxl
$ pip install 'openpyxl==2.0.0'
Downloading/unpacking openpyxl==2.0.0
  Could not find a version that satisfies the requirement openpyxl==2.0.0 (from versions: 1.7.0, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 2.0.2, 1.1.0, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.2.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.6.1, 1.6.2, 1.7.0, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 2.0.2, 2.0.3)

あれ?2.0.0無かった。。。

$ sudo pip install 'openpyxl<=2.0'

確認

$ ipython

In [1]: import openpyxl

In [2]: openpyxl.__version__
Out[2]: '1.8.6'

In [3]: import pandas

In [4]:

とりあえず import pandas してもエラー出なくなった。